Information

说明

返回插件信息

函数结构:

  • string Information(string Path)

返回值说明:

  • 返回类型:string
  • 返回说明:返回插件信息
参数:
参数名 类型 说明
Path string 机器人的配置目录 如“E:\Config\724583668”
易语言函数体
.版本 2

.子程序 Information, 文本型, 公开, 返回插件信息 请勿修改函数名
.参数 机器人配置目录, 文本型, , 机器人的配置目录 如“E:\Config\724583668”

FirstLoad

说明

插件被加载 返回假阻止加载

函数结构:

  • bool FirstLoad(string 机器人配置目录,string 接口版本号,string 机器人号,string runtime_auth_code)

返回值说明:

  • 返回类型:bool
  • 返回说明:插件被加载 返回假阻止加载
参数:
参数名 类型 说明
机器人配置目录 文本型 机器人的配置目录 如“E:\Config\724583668”
接口版本号 文本型 接口版本号 如 2.0 如果插件版本号更改 插件机制必然更改
机器人号 文本型 机器人QQ号码
runtime_auth_code 文本型 运行时校验码
易语言函数体
.版本 2

.子程序 FirstLoad, 逻辑型, 公开, 插件被加载 返回假阻止加载
.参数 机器人配置目录, 文本型, , 机器人的配置目录 如“E:\Config\724583668”
.参数 接口版本号, 文本型, , 接口版本号 如 2.0 如果插件版本号更改 插件机制必然更改
.参数 机器人号, 文本型
.参数 runtime_auth_code, 文本型

PluginInstall

说明

安装时调用 返回假则阻止安装

函数结构:

  • bool PluginInstall(string 机器人配置目录,string 接口版本号,int 安装类型,int 上一插件版本号)

返回值说明:

  • 返回类型:bool
  • 返回说明:安装时调用 返回假则阻止安装
参数:
参数名 类型 说明
机器人配置目录 文本型 机器人的配置目录 如“E:\Config\724583668”
接口版本号 文本型 接口版本号 如 2.0 如果插件版本号更改 插件机制必然更改
安装类型 整数型 0为全新安装 1为替换(升级)
上一插件版本号 整数型 插件打包是输入的版本号 当安装类型为1时有效
易语言函数体
.版本 2

.子程序 PluginInstall, 逻辑型, 公开, 安装时调用 返回假则阻止安装
.参数 机器人配置目录, 文本型, , 机器人的配置目录 如“E:\Config\724583668”
.参数 接口版本号, 文本型, , 接口版本号 如 2.0 如果插件版本号更改 插件机制必然更改
.参数 安装类型, 整数型, , 0为全新安装 1为替换(升级)
.参数 上一插件版本号, 整数型, , 插件打包是输入的版本号 当安装类型为1时有效

PluginStart

说明

插件启动时调用 返回假则阻止启动

函数结构:

  • bool PluginStart(string Path)

返回值说明:

  • 返回类型:bool
  • 返回说明:插件启动时调用 返回假则阻止启动
参数:
参数名 类型 说明
Path string 机器人的配置目录 如“E:\Config\724583668”
易语言函数体
.版本 2

.子程序 PluginStart, 逻辑型, 公开, 插件启动时调用 返回假则阻止启动
.参数 机器人配置目录, 文本型, , 机器人的配置目录 如“E:\Config\724583668”

PluginStop

说明

插件停止时调用 返回假则阻止停止

函数结构:

  • bool PluginStop(string Path)

返回值说明:

  • 返回类型:bool
  • 返回说明:插件停止时调用 返回假则阻止停止
参数:
参数名 类型 说明
Path string 机器人的配置目录 如“E:\Config\724583668”
易语言函数体
.版本 2

.子程序 PluginStop, 逻辑型, 公开, 插件停止时调用  返回假则阻止停止
.参数 机器人配置目录, 文本型, , 机器人的配置目录 如“E:\Config\724583668”

PluginEnd

说明

插件每次被停止 包括手动停止 机器人关闭 插件被卸载

函数结构:

  • PluginEnd(string Path)

返回值说明:

  • 返回类型:无
  • 返回说明:插件每次被停止 包括手动停止 机器人关闭 插件被卸载
参数:
参数名 类型 说明
Path string 机器人的配置目录 如“E:\Config\724583668”
易语言函数体
.版本 2

.子程序 PluginEnd, , 公开, 插件每次被停止 包括手动停止 机器人关闭 插件被卸载
.参数 机器人配置目录, 文本型, , 机器人的配置目录 如“E:\Config\724583668”

PluginUninstall

说明

卸载时调用 返回假则阻止卸载

函数结构:

  • bool PluginUninstall(string Path)

返回值说明:

  • 返回类型:bool
  • 返回说明:卸载时调用 返回假则阻止卸载
参数:
参数名 类型 说明
Path string 机器人的配置目录 如“E:\Config\724583668”
易语言函数体
.版本 2

.子程序 PluginUninstall, 逻辑型, 公开, 卸载时调用 返回假则阻止卸载
.参数 机器人配置目录, 文本型, , 机器人的配置目录 如“E:\Config\724583668”

Api通讯函数

说明

加群加好友回调函数

函数结构:

  • Api通讯函数(string 编号,int 类型,int 代码,int 加好友类型,string 对象QQ或群,string 消息)

返回值说明:

  • 返回类型:无
  • 返回说明:加群加好友回调函数
参数:
参数名 类型 说明
编号 文本型
类型 整数型 1、加群加好友需要验证码 2、加群加好友完成 3、加群加好友失败 4、需要验证码问题(暂不支持)
代码 整数型 当类型为3时有效 1、加好友加群超时 2、对方禁止加好友加群 3、已经是好友
加好友类型 整数型
对象QQ或群 文本型
消息 文本型 当类型为1时 是验证码图片路径 当类型为2、3或4时是“加好友+QQ号”或“加群+群号”
易语言函数体
.版本 2

.子程序 Api通讯函数
.参数 编号, 文本型
.参数 类型, 整数型, , 1、加群加好友需要验证码 2、加群加好友完成 3、加群加好友失败 4、需要验证码问题(暂不支持)
.参数 代码, 整数型, , 当类型为3时有效 1、加好友加群超时 2、对方禁止加好友加群 3、已经是好友
.参数 加好友类型, 整数型
.参数 对象QQ或群, 文本型
.参数 消息, 文本型, , 当类型为1时 是验证码图片路径 当类型为2、3或4时是“加好友+QQ号”或“加群+群号”如“加好友480398”

Callback

参数名 类型 说明
Events 整数型 1、QQ消息 2、群消息 3、讨论组消息 4、加好友请求 5、加群请求 6、被邀请加群请求 7、退群消息 8、被踢出群 9、群成员更改了群名片 10、临时会话 11、好友状态更改 12、好友更改了个性签名 13、第一次打开聊天窗口消息 14、抖动窗口消息 15、被置(被取消)群管理员 16、加群消息(机器人非群管理) 17、群动态 18、同意机器人加好友 19、同意机器人入群 20、群成员邀请他人入群 21、禁言消息 22、加群消息(允许任何人) 23、被删好友 24、被加好友(允许任何人) 25、解散群
Msg 文本型 消息内容 当Events=8时为踢成员的管理员 当Events=9时为更改后的名片 当Events=11时为更改后的状态 当Events=12时为更改后的个性签名 当Events=15时 Msg=“1”是被置为管理员 Msg=“0”是被取消管理员 当Events=16时 Msg是同意进群的管理员 当Events=20时 Msg是发送邀请的群成员
Sender 文本型 发送者 当Events=6时为邀请者 当Events=20时为被邀请者
Nick 文本型 发送者昵称
QunNum 文本型 群号码
QunNick 文本型 群昵称
QunCard 文本型 群名片
RobotQQ 文本型 机器人QQ号码
附加信息 文本型 取附加信息(附加信息)
机器人配置目录 文本型 机器人的配置目录 如“E:\Config\724583668”
文档更新时间: 2019-03-09 10:17   作者:admin